CVE stands for Common Vulnerabilities and Exposures, which is an industry standard way to track security issues in software applications. They are tracked centrally in the National Vulnerability Database 2. NVD is a product of the NIST Computer Security Division.
Although many CVEs mention WordPress, only a few are applicable. Here is a list of CVEs that mention WordPress, organized by year, and whether the CVE impacts WordPress Plugins, the core programming, WordPress.com, or another aspect of WordPress, as well as which version of WordPress was impacted. The Date used is the date of the report going public and not the day the vulnerability was discovered.
In terms of security of your WordPress blog, being on the latest version of WordPress is all you need. WordPress generally fixes vulnerabilities and releases an upgrade or security update version before they become public and are issued a CVE.
WordPress uses third party applications like the Apache webserver, the PHP scripting language and the MySQL database. You should keep these versions current as well. Reports for these third party applications are not listed on this page.
Additionally you can take precaution actions by using Suhosin, an advanced protection system for PHP installations.
1 total CVEs, 1 apply to core, 0 to legacy, and 0 are invalid. (for 2010 only core CVEs listed here)
16 total CVEs, 1 apply to plugins, 15 apply to core, 0 to legacy, and 0 are invalid. (for 2009 mostly core CVEs listed here, too many plugins)
|CVE-2009-3890||2009-11-17||Core||File Upload Bypass|
|CVE-2009-3622||2009-10-23||Core||Denial Of Service|
|CVE-2009-2432||2009-07-10||Core||Information Disclosure (as well for WPMU)|
|CVE-2009-2336||2009-07-10||Core||User Information Disclosure|
|CVE-2009-2335||2009-07-10||Core||User Information Disclosure|
|CVE-2009-2334||2009-07-10||Core||Privelege Escalation / Information Disclosure|
|CVE-2008-6767||2009-04-28||Core||Denial Of Service|
|CVE-2009-1030||2009-03-20||Core||WordPress MU below 2.7|
59 total CVEs, 40 apply to plugins, 10 apply to core, 3 to legacy, and 6 are invalid.
|CVE-2008-6767||2009-04-28||Invalid||Same Report as in CVE-2008-6762|
|CVE-2008-5695||2008-12-19||Legacy Core||WordPress MU before 1.3.2, and WordPress 2.3.2 and earlier|
|CVE-2008-5278||2008-11-28||Core||WordPress before 2.6.5|
|CVE-2008-4769||2008-10-28||Core||WordPress 2.3.3 and earlier, and 2.5|
|CVE-2008-4671||2008-10-22||Core||Wordpress MU before 2.6|
|CVE-2008-4106||2008-09-18||Core||WordPress before 2.6.2|
|CVE-2008-3747||2008-08-27||Core||WordPress before 2.6.1|
|CVE-2008-2392||2008-05-21||Invalid||"Admin" user has ability to edit plugins and upload files if file permissions allow- this is intentional.|
|CVE-2008-2146||2008-05-12||Invalid||Describes a known issue in WordPress 2.2, which was released more than a year before. (Covered by previous CVE.) The problem described was fixed 9 months before this report.|
|CVE-2008-2068||2008-05-02||Core||"Unspecified vectors" were never publicly reported, but fixed in 2.5.1.|
|CVE-2008-1930||2008-04-28||Core||Cookie-based cryptographic splicing attack. Fixed in 2.5.1 prior to disclosure.|
|CVE-2008-1304||2008-03-12||WordPress.com||XSS in invite system on WordPress.com, did not apply to WordPress.org blogs at all.|
|CVE-2008-0664||2008-02-07||Core||If registration was enabled, an undisclosed vulnerability in XML-RPC. Fixed by 2.5 prior to disclosure.|
|CVE-2008-0196||2008-01-09||Legacy Core||Problem in legacy 2.0 branch of WordPress, not applicable to current versions.|
|CVE-2008-0195||2008-01-09||Legacy Core||Disclosure in legacy 2.0 branch of WordPress, not applicable to current versions.|
|CVE-2008-0194||2008-01-09||Plugin||Fixed in version 2.1.0 of this plugin, released 7 months prior to this CVE|
|CVE-2008-0193||2008-01-09||Plugin||Fixed in version 2.1.0 of this plugin, released 7 months prior to this CVE|
|CVE-2008-0192||2008-01-09||Invalid||Problem already fixed by 2.0.10 release 9 months before this CVE.|
|CVE-2008-0191||2008-01-09||Invalid||Could not recreate in current release (2.3.2) at that time|