WordPress.org

Codex

es:Hacking WordPress

En versiones muy antiguas de WordPress, la única manera de cambiar el funcionamiento de WordPress era a través de los "hacks", es decir, modificando el núcleo de los archivos de WordPress. Sin embargo, desde la versión 1.5, WordPress ha ofrecido los plugins y los temas capaces como mecanismos de modifficar todo lo que WordPress hace, desde su diseño hasta su funcionalidad, por eso los hacks rara vez son necesarios, y, desde luego, no se recomiendan.

Los hacks no son oficialmente soportados por WordPress. Úsalos bajo tú propio riesgo.

Usando hacks en WordPress

Aunque los hacks no son recomendables, y desde la versión 1.5 de WordPress casi no se utilizan, pero para totalidad, este artículo sigue en el archivo my-hacks.php, el cual lo puedes activar y usar para "hacks". Básicamente, puedes poner funciones PHP y variables en este archivo (el cual va dentro el directorio de instalación de WordPress), y si lo activas, será cargado justo después de los plugins cuando WordPress empiece.

Para activar my-hacks.php:

  • En el Panel de Administración, elige Opciones > Misceláneas.
  • En la parte inferior de la página, haz click en la casilla de Usar soporte de archivo my-hacks.php para poner un ticket en ella.
  • Haz click en Guardar cambios para guardar la opción cambiada.

IMPORTANTE: desde la versión 2.8 el archivo my-hacks.php ya no es soportado. En su lugar, ocupe el archivo functions.php que debe ubicarse en la carpeta de su actual theme activo.